Installer PHP 5.3.1 sur Ubuntu Karmic koala 9.10

J’ai récemment voulu installer sur mon serveur web le (tout nouveau) agrégateur de flux RSS (avec API distante REST) OpenWebReader.
L’auteur, pour avoir un développement plus aisé et moderne, a choisi la dernière version de PHP, 5.3
Sauf que sur Ubuntu 9.10, la version de PHP packagée est la 5.2.6
En général, dans ces cas, on a plutôt le réflexe de mettre à jour ses dépôts, dans /etc/apt/sources.list et de rajouter le dépôt qui va bien, qui rajoute en l’occurrence php 5.3.
C’est bien ce que j’avais commencé à faire, en suivant ce billet.
Mais malheureusement, plein de dépendances ont sauté : phpmyadmin, apache2-mod-php5, etc… du coup, machine arrière vers PHP 5.2.6 🙁
Retour aux sources, j’ai téléchargé sur php.net la version 5.3.1 de PHP

, je l’ai détarré dans mon home directory :

et avant de le compiler, je suis allé chercher tout plein de librairies :

et là, dans mon répertoire de php 5.3.1 , j’ai pu compiler :

Si vous avez un problème lors du configure c’est qu’il vous manque une librairie…
Ensuite, maintenant que l’on a une version de Php 5.3.1 compilé, il faut la référencer à Apache2, et pour ne rien casser aux dépendances, on trafique juste une petit peu /etc/apache2/mods-available/php5.load :

et là, le tour est joué, il suffit de redémarrer Apache2 pour que Php 5.3.1 soit chargé.
En fait, je me suis beaucoup inspiré de ce billet, sauf qu’à la fin, je vous conseille de ne pas faire le make install, car votre système risque de ne plus être en cohérence avec les dépots

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée.

Le temps imparti est dépassé. Merci de saisir de nouveau le CAPTCHA.